View Issue Details

IDProjectCategoryView StatusLast Update
0009629phpList 3 applicationBounce Managementpublic13-02-09 11:32
Reporterhorus 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.10.4 
Target VersionFixed in Version 
Summary0009629: Bounce-user and bounce-regex association
DescriptionIn page bounce.php&s=0&id=[bounceid] I can delete a bounce but the bounce association with user seems not to be deleted so in page ?page=userhistory&id=[userid] I still see a link to it. If I click on link I get an error: "Fatal Error: No such Record" and I receive a mail with:
 An error has occurred in the Mailinglist System
 URL: /phplist/admin/?page=bounce&id=[bounceid]
 Error: No such Record

Same behaviour with bounce-regex association in page ?page=bouncerule&id=[regexid]
Additional InformationI try to find out the problem and I think it's in bounce.php line 76 where system delete directly the bounce and doesn't use the deleteBounce function in lib.php line 729.
TagsNo tags attached.

Activities

user4402

13-02-09 11:32

  ~0050475

Closing issue because it is too old. If you feel it is still relevant please add again and give the new context. Thanks!