View Issue Details

IDProjectCategoryView StatusLast Update
0009105phplist applicationMessage Managementpublic04-06-13 17:30
Reporterdecay 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.4 
Target VersionFixed in Version2.11.10 
Summary0009105: Anchors in HTML get converted to links in text mails
DescriptionAnchors in the message being sent are treated as normal links and are converted to <#anchorname> in the text version of the message sent. Imho this should be filtered, because the anchors are useless in the text view anyway..
TagsNo tags attached.

Relationships

related to 0015193 resolvedmichiel Portions of Content are Omitted in Plain Text from Plain Text Messages with <a> Tag 
related to 0015275 resolvedmichiel stripHTML is too greedy when matching links 

Activities

Cord

15-06-08 09:28

reporter   ~0049650

Unfortunately, this issue is a regression and back again in version 2.10.5.

I've described the problem in the following posting:

http://forums.phplist.com/viewtopic.php?t=13060&sid=4a27def07de8812f299014bc59f3541b

I encounter the following problem whenever I compose HTML-newsletters with anchors and links to those anchors in the HTML-mail:

The HTML-mail is perfect, but the text version includes (useless and hideous) html-leftovers like <1> wherever there are links to anchors.

An example:

Code:
1) Gilt der Datenschutz für Lehrer nicht? <1>

2) McKinsey: PISA-Ergebnisse haben nichts mit Schulsystem zu tun <2>

3) Merkblätter und Formulare des Kultusministeriums <3>

4) Zur Erinnerung zwei herzliche Einladungen: <4>


Is this a bug or is there a way of cleaning html-code in text-mails?

Another Problem is that (in text-mails) there is a line-break after what is a link (in html-mails).

The problem is, that if there is a full-stop or a parenthesis after the link, this gets moved to a new line.

Example:
Code:
(Aktenzeichen 15 U/142/07, Quelle: http://www.computerwoche.de
)

michiel

04-06-13 17:30

manager   ~0052092

tried this in trunk and seems to work ok