View Issue Details

IDProjectCategoryView StatusLast Update
0008457phplist applicationBounce Managementpublic18-02-08 14:06
Reporterorock 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.3 
Target Version2.10.7Fixed in Version2.10.4 
Summary0008457: $bounce_unsubscribe_t[h]reshold problem upgrading from 2.10.2 to 2.10.3
Descriptionwe made an unknowing mistake when upgrading from 2.10.2 to 2.10.3 of copying lines from our previous config.php to the new one.

we ended up with:
$bounce_unsubscribe_treshold = 5;

instead of:
$bounce_unsubscribe_threshold = 5;

this caused our users to be unconfirmed on their first bounce since $bounce_unsubscribe_threshold is unset.

i noticed in admin/init.php some code attempting to correct this spelling error in previous version but it is incorrect and will never kick in.

the code reads:

## spelling mistake in earlier version, make sure to set it correctly
if (!isset($bounce_unsubscribe_threshold) && isset($bounce_unsubscribe_threshold)) {
  $bounce_unsubscribe_threshold = $bounce_unsubscribe_treshold;
}

this checks if the correct value ($bounce_unsubscribe_threshold) IS NOT SET and whether the correct value ($bounce_unsubscribe_threshold) IS SET. this will obviously never be true and clearly should be a check for correct value ($bounce_unsubscribe_threshold) NOT SET and for incorrect value ($bounce_unsubscribe_treshold) SET.

we have fixed the problem by correcting the spelling in the config.php file but this was confounding us for a while be cause $bounce_unsubscribe_threshold looks soooo much like $bounce_unsubscribe_treshold.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
has duplicate 0008795 resolvedmichiel Config.php file has misspelled variable 

Activities

michiel

07-11-06 15:11

manager   ~0020748

my head spins as well, and obviously did when I was trying to set the workaround. Thanks for finding that

orock

07-11-06 16:09

reporter   ~0020752

glad to help.