View Issue Details

IDProjectCategoryView StatusLast Update
0008394phplist applicationSubscribe Processpublic18-02-08 14:06
Reporterh2b2 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.3 
Target Version2.10.7Fixed in Version2.10.4 
Summary0008394: "Colon" (:) or "equal" (=) in confirmation preferences change message
DescriptionThis is a trivial matter reported in the forum by Flo ( http://forums.phplist.com/viewtopic.php?t=6957 ).

The message users receive upon changing their preferences looks like this:
  Email : name@domain.com
  Send HTML email : Yes
  Firstname = Peter

As you can see, attributes have an 'equal' sign, instead of a colon. This seems easy to correct, though I didn't test it:

In version 2.10.3, subscribelib2.php, line 485, change this:
   $datachange .= strip_tags($attribute["name"]) . " = ";

to this:
   $datachange .= strip_tags($attribute["name"]) . " : ";

TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

There are no notes attached to this issue.