View Issue Details

IDProjectCategoryView StatusLast Update
0007684phplist applicationHTML Email Supportpublic30-05-12 20:05
Reporterbhugh 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version4.0.xFixed in Version2.11.7 
Summary0007684: cache problems with included web page in message
DescriptionEvidently some servers do not reliably change the "last-modified" header to when a file is actually changed.

Result is problems when a message includes a web page via the [URL:http: . . . ] feature.

The person includes the web page, sends a test message, realizes the web page needs to be changed, changes the web page, sends another test message--which is exactly the same as the previous because the web page is still cached (under some servers/situations the "last-modified" header doesn't change at all--at least not until maybe 24 hours later).

Also in an error perhaps related, the [URL:] functionality doesn't seem to differentiate between web pages like this:

  http://abc.com/script.php
  http://abc.com/script.php?parameter=42

It seems that both changing the [URL:] parameter within a message between these two will give exactly the same result both times, even though the two pages may in reality be wildly different with the different parameter.


Some details and a possible (thought perhaps not optimal?) solution here:

[url]http://forums.phplist.com/viewtopic.php?t=2658&postdays=0&postorder=asc&start=45[/url]
TagsNo tags attached.

Relationships

related to 0002705 closed PHPList v2.11 release 

Activities

bhugh

05-09-06 00:16

reporter   ~0017940

A possible solution would be to include a check-off box on the "send a message" page, "reload embedded web page".

Sort of the equivalent of the "refresh" button found on web browsers.

michiel

05-09-06 02:24

manager   ~0017944

you can also set the FETCH TIMEOUT to be very low, but I guess that's not that nice once you actually send the message, because it would dramatically delay sending it.

It's odd that URLs with a parameter are not recognised as different ones. I would think that's not the case.

michiel

04-10-06 16:40

manager   ~0019569

changed last-modified to use time() instead of HTTP header

rayshiva

27-01-08 21:06

reporter   ~0040111

This is not fixed for me, I am still having this problem.

I am forced to make duplicate copies of my .php pages that I want to send as an email, so that it does not re-send the cached version. Is there a way to manually clear the cache? Or can you help me to figure out how to resolve this issue? I normally would have my other admins send the newsletters, but this issue forces me to do it personally.

thanks.

Ray Shiva
admin@mahasiddhas.org

espiegel123

10-12-09 04:09

reporter   ~0050798

I am using 2.10.10 and this is still a problem. I have to manually go into the database and delete the cache records to get PHPLIST to fetch the current copy of the page

michiel

30-05-12 20:05

manager   ~0051650

all cache is cleared every time before sending a test message