View Issue Details

IDProjectCategoryView StatusLast Update
0007623phplist applicationRSSpublic18-02-08 14:16
Reporterbhugh 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.3 
Summary0007623: Purge RSS doesn't work, simple fix needed
DescriptionI was trying to purge the RSS entries that had been loaded previously, using the purgerss link at

http://mobikefed.dreamhosters.com/phplist/admin/?page=purgerss

The page says "Enter the number of days to go back purging entries" and has a default value of 30.

So I enter 30. No go.

I enter a few more numbers. It does nothing. Every time the response is "0 RSS items purged".

On a lark I enter "-30". What do you know, every item purged successfully.

Obviously the code is set up so positive numbers stretch from today forward and negatives stretch backwards.

The fix is simple, either change the documentation to tell people to enter a negative number OR (better), change a + to - sign somewhere.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

michiel

01-09-06 13:40

manager   ~0017797

ah, nice find

michiel

03-10-06 19:54

manager   ~0019529

Ah, just looked into this, but the problem is terminology.

Days to go back, means "up to how many days ago to purge entries"

that is:

30 means all entries that are older than 30 days are purged, and entries that are less than 30 days old are kept.

So, the functionality is correct, but the terminology is confusing.

michiel

03-10-06 19:56

manager   ~0019530

added a little more explanation in the page