View Issue Details

IDProjectCategoryView StatusLast Update
0007595phplist applicationAll Otherpublic18-02-08 14:19
Reporterrhinkle 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version4.0.xFixed in Version2.10.3 
Summary0007595: Link Click Tracking
DescriptionWhile the link tracking feature appears to work most of the time and adds a great benefit to PHPList, it does not appear to work is the URL does not end in either a slash (/) or with a filename containing and extension. For example, clicks of the following URLs are tracked:

http://www.tastefullysimple.com
http://www.tastefullysimple.com/web/thinkle/

However... links to the following URL are not tracked, even though this is a valid URL.

http://www.tastefullysimple.com/web/thinkle

Having the URL end in a / or with a file extension such as .com or .htm seems to be the key for the link to be replaced with the code required to do the tracking.
TagsNo tags attached.

Relationships

related to 0002705 closed PHPList v2.11 release 
related to 0004137 resolvedmichiel text emails click tracking track wrong URLs 

Activities

michiel

30-08-06 20:50

manager   ~0017645

yes, if one of the first links in your email is the top URL to the domain, then the rest of them are tracked badly. This is a bug.

You can avoid it, by not having a link to the main website at the top.