View Issue Details

IDProjectCategoryView StatusLast Update
0007418phplist applicationRSSpublic18-02-08 14:16
Reporterakolthoff 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.3 
Summary0007418: Typo in rsslib.php
DescriptionLine 76 of the distribution file public_html/lists/admin/rsslib.php reads:

    $treshold = getConfig("rsstheshold");

missing the 'r'. It must be corrected to:

    $treshold = getConfig("rssthreshold");
Additional InformationBecause of this typo the configured "Minimum amount of items to send in an RSS feed" always would be ignored.

I have noticed that in the MySQL database in the phplist_config table an item 'rsstheshold' (the wrong spelling) exists, additional to the correct 'rssthreshold' item.

Also there are inconsistencies regarding the spelling of "threshold" in several files; sometimes in strings and variable names it is spelled as "treshold", for instance here in processqueue.php:

$rss_content_treshold = sprintf('%d',getConfig("rssthreshold"));

For the sake of clarity this should be corrected.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

michiel

17-08-06 14:32

manager   ~0017002

ah, that's a great find. thanks