View Issue Details

IDProjectCategoryView StatusLast Update
0006638phplist applicationBounce Managementpublic18-02-08 14:08
Reporterhola 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.5 
Summary0006638: bounce.php
DescriptionIs it me or does the bounce.php file ignore my tick to delete user? I had a look at bounce.php and it seems to get the deleteuser checkbox using a $_POST when on the html form generated on the bounce page the form method has been set to GET??

Plus the $deletebounce var seems to be set with true or false outside of the bounce file because its value is honoured and I can delete or not delete bounce records.

Help!
TagsNo tags attached.

Relationships

duplicate of 0005444 resolvedmichiel Features in bounce 
related to 0003721 closed phplist 2.10.x 

Activities

h2b2

27-07-07 14:38

manager   ~0029828

Tomwing reported "BUG when trying to delete a BOUNCE" on the forum, http://forums.phplist.com/viewtopic.php?p=33934#33934 and includes the followsing fix:


File: bounces.php

Line Number 6:

// This is wrong, because the delete command is a GET Link:
if (isset($_POST['delete']) && $_POST['delete']) {
# delete the index in delete
print $GLOBALS['I18N']->get('deleting').' '.$_POST['delete']."..\n";
if ($GLOBALS["require_login"] && !isSuperUser()) {
} else {
deleteBounce($_POST['delete']);
}
print $GLOBALS['I18N']->get('done') . "
<hr>
\n";
}

// this is right:
if (isset($_REQUEST['delete']) && $_REQUEST['delete']) {
# delete the index in delete
print $GLOBALS['I18N']->get('deleting').' '.$_POST['delete']."..\n";
if ($GLOBALS["require_login"] && !isSuperUser()) {
} else {
deleteBounce($_REQUEST['delete']);
}
print $GLOBALS['I18N']->get('done') . "
<hr>
\n";
}

user1308

27-07-07 16:57

  ~0029835

Thanks, will be implemented in 2.10.5
And btw, it was the bounces.php file, no bounce.php