View Issue Details

IDProjectCategoryView StatusLast Update
0006481phpList 3 applicationCampaign Managementpublic10-02-09 10:26
Reporterhola 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.10.2 
Target VersionFixed in Version 
Summary0006481: Database size due to clickstats
DescriptionHi,

I just ran a test with an email campaign and click track activated

define('CLICKTRACK',1);
define('CLICKTRACK_SHOWDETAIL',1);

3 subscribers - 5 links within email

Event:

subscriber 1 clicked 3 links twice
subscriber 2 click 3 links twice
subscriber clicked nothing

Table record stats:
1) phplist_linktrack = 15 rows for the message - which is 3 subscribers X 5 links in email.

2) phplist_linktrack_userclick = 42 rows - which I think is recording each click hence your warning on "show detail" option in config file.

I have two questions as I can see that the 2 tables will reach massive sizes when you send out an email with say 5 links to 5000 subscribers!

1) Do we need to enter in a record in the linktrack before a click is registered? whats the reason behind this? Is it to work out a particular stat?

2) Is there a way we could be more smarter on recording click events in linktrack_userclick?

Cheers
Marc


TagsNo tags attached.

Relationships

related to 0006473 resolvedmichiel clicktracking causes excessive database load 

Activities

user4402

10-02-09 10:26

  ~0050413

Closing issue because it is too old. If you feel it is still relevant please add again and give the new context. Thanks!