View Issue Details

IDProjectCategoryView StatusLast Update
0006419phplist applicationAll Otherpublic18-02-08 14:06
Reporterhakan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.4 
Summary0006419: Short tags are not supported on everywhere
DescriptionHi,

the files:
tree lists/admin/commonlib/
lists/admin/commonlib/
|-- lib
| |-- accesscheck.php
| |-- errorlib.php
| |-- interfacelib.php
| |-- magic_quotes.php
| |-- oldphp_vars.php
| `-- userlib.php
`-- pages
    |-- attributes.php
    |-- dbcheck.php
    |-- importcsv.php
    |-- user.php
    |-- usermgt.php
    `-- users.php

have short open tags "<?" instead of "<?php".

For better portability "<?php" should be used, because short tags are not supported on every installation of PHP.

See also:
http://www.php.net/manual/en/language.basic-syntax.php

Regards, Hakan
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
related to 0001175 resolvedmichiel Use of short tags 
related to 0006682 resolved PHP Short Tags 

Activities

michiel

19-05-06 02:16

manager   ~0013807

you can use "scripts/short2long.sh" to make the conversion. Sometimes I forget to do that.

hakan

06-06-06 12:30

reporter   ~0014177

Why not skip the usage of short open tags and replace all "<?" with "<?php"?
It would make PHPlist more portable.

user1822

16-07-07 20:22

  ~0029411

Replaced all <? by <?php
Replaced all <?= by <?php echo