View Issue Details

IDProjectCategoryView StatusLast Update
0006272phplist applicationInternationalization (l18n)public18-02-08 14:06
Reporterh2b2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.5 
Summary0006272: $strYouAreBlacklisted string in language files is not used fo output
DescriptionThe $strYouAreBlacklisted string in the ".inc" language files does not seem to be used for output.

Instead the YouAreBlacklisted string in admin/lan/en/frontend.php is used, which is in English. This makes customizing and/or running phplist with other language files than english a bit problematic.

An obvious workaround is to translate YouAreBlacklisted string in frontend.php, but a more elegant solution would be nice...

Stepped on this problem when unsubscribing a user and later trying to subscribe him again.
_________________
Al Stillero
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

michiel

02-05-06 13:49

manager   ~0013263

ah, good point. I was trying to move the frontend translations into the backend, but that woulnd't work for frontend translations that have no corresponding backend translation.

I'll check it out.

user1822

16-07-07 14:42

  ~0029384

0006272: $strYouAreBlacklisted string in language files is not used fo output
Changed from I18N object to string globals
Removed from frontend.php (commented out since relation with webbler is unclear to me)