View Issue Details

IDProjectCategoryView StatusLast Update
0005866phplist applicationAll Otherpublic18-02-08 14:16
Reportertoprach 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.3 
Summary0005866: Link in TEXT Mail is not parsed if Link is preceeded by newline
DescriptionHow to reproduce:
Create HTML Message with text

google.at>google</a>
sometext before <a href=

the derived TEXT will look like this:

google[/URLTEXT]http://google.at/[/LINK]
sometext before google <http://www.google.at/>

I have tried this with click track on and off - it was always reproduceable.
as soon as you add a SPACE before the link it will be parsed correctly in the Text email.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
related to 0006570 closed stripHTML() problem with certain HTML code 

Activities

michiel

28-04-06 00:59

manager   ~0013162

yes, that's a weird one, and I can reproduce it. Will have a look to see what's up

michiel

28-04-06 01:34

manager   ~0013165


in sendemaillib.php

in the function stripHTML

there's a line commented,
$text = preg_replace("/\n/","###NL###",$text);

if you uncomment that line, does that fix it? For me it seems to add a space before the link, but at least parsing seems to work better. Now the issue is to find where that space comes from.

michiel

21-06-06 15:57

manager   ~0014655

fixed in CVS

michiel

21-06-06 16:01

manager   ~0014656

by the way, your example

< a href="google.at>google</a>
sometext before < a href="google.at">google</a>

misses a " in the first link, so it will still fail.