View Issue Details

IDProjectCategoryView StatusLast Update
0005786phplist applicationAll Otherpublic18-02-08 14:08
ReporterIProto 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.5 
Summary0005786: System messages don't parse [DOMAIN] or [WEBSITE]
DescriptionWhen a user puts [DOMAIN] or [WEBSITE] or www.mysite.com into a system message users will just get [DOMAIN] or [WEBSITE] in their e-mails. The problem appears to be that when the message is loaded into the edit textbox any instance of www.mysite.com will be translated into [DOMAIN] however when the information is saved it is not translated back. A suggested fix is posted here: http://www.phplist.com/forums/viewtopic.php?t=4925
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

user1822

21-08-07 19:28

  ~0030813

I tested and can confirm this happens when you enter [DOMAIN] and use Save and Activate. Using other scenario's I could not reproduce this issue.

Replacing [DOMAIN] with the domain gets done in defaultconfig.getConfig. This function is only called when building the page, as we do after 'Save'ing the page. After an 'Activate' the page is only stored. defaultconfig.getUserConfig is used when sending mail.

Added parsing of [DOMAIN\] and [WEBSITE\] to getUserConfig.

Parsing should be done only in one place. So maybe Later: Combine getConfig and this one?