View Issue Details

IDProjectCategoryView StatusLast Update
0005513phpList 3 applicationCampaign Managementpublic21-01-08 18:50
Reporterjotazzu 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version2.10.2 
Target VersionFixed in Version 
Summary0005513: X-lines in message headers seem to raise spam rate significantly
DescriptionIn the discussion thread "Hotmail not receiving my newsletters ..." in the forum (http://www.phplist.com/forums/viewtopic.php?t=4404) an interesting discovery has been made by Slugger.
He has sent the same message with and without X-lines in the email header. With X-lines it was sorted to the spam folder without not. Also the spam ratings of Eudora and Spamassassin are significantly higher if the X-lines are contained.

With this negative side effects it should be considered to avoid such lines in future versions.
TagsNo tags attached.

Relationships

related to 0002705 closed PHPList v2.11 release 

Activities

michiel

17-02-06 18:35

manager   ~0010821

that's a very interesting find indeed. I can't remember coding X-lines in the code, but I guess phpmailer might add that automatically. Should be possible to take that out.

Would be nice to find more things like that.

osoell

11-10-06 00:51

reporter   ~0019808

The x-mailer could go, although specifying your mailer shouldn't cause any grief in spamassassin. I am not saying that I know it doesn't, though.

The x-messageID header is good for bounce processing - you can tell which message bounced. "bounced" these days really doesn't mean bounced anymore - it could be that it was marked as spam and returned. This way we can see if a particular messageID has a higher bounce rate than others to the same list.

Likewise, x-listuser could go if we are using VERP, since various other headers are written with the address we're sending to, but it is sorta nice to have the user ID, not just email.

putting in the List-Unsubscribe/List-Subscribe/List-Info headers might even LOWER the spam rate since we are trying to be good - read about here
http://www.ietf.org/rfc/rfc2369.txt

the X-Priority header can definitely go, if it doesn't exist, the client will assume priority of 3 which is fine.

The precedence: bulk header might possibly be anachronistic. I dunno. I wonder if mail systems or clients even worry about it anymore.

cheers,
-o

h2b2

27-11-06 03:32

manager   ~0021418

This forum post could perhaps be related: http://forums.phplist.com/viewtopic.php?p=21272#21272

h2b2

23-12-06 14:13

manager   ~0022169

Commenting out all X-mailer lines indiscriminately may cause problems, as suggested by jameswynen in a forum post:

"I have figured out the problem. It was caused by me, after reviewing the code for the bounce processor i realized what had happened by commenting out certain headers inserted in an email. I removed the x-mailer: userID . I did this in response to get a better delivery rate into mailboxes, which does work, but at the cost of the sent messages tracking in the users and bounce processing done by user ID (It is not done by email address in the bounce/return) You may want to tag this onto the thread about commenting out those header fields as an deleterious effect of doing so. I have not performed a test on this theory but looking at the code I am sure that is the problem."
Ref: http://forums.phplist.com/viewtopic.php?p=26093#26093

h2b2

06-01-07 07:43

manager   ~0022280

This thread about some disconcerting X-lines might be (vaguely) related too: http://forums.phplist.com/viewtopic.php?t=7838

user1822

04-09-07 19:36

  ~0031666

For explanation why we won't fix it (for now) see http://forums.phplist.com/viewtopic.php?t=4639&postdays=0&postorder=asc&start=30