View Issue Details

IDProjectCategoryView StatusLast Update
0000549phpList 3 applicationGeneralpublic03-04-04 23:37
Reportertruefresco 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000549: FCKeditor and PHPlist
DescriptionI am trying to use FCKeditor, but with no success:

I can compose message, upload images, browse and insert existing images, but when I click "add message" I get "Please enter message" and blank editor...
For some reason message entry does not get passed.
TagsNo tags attached.

Activities

truefresco

23-08-03 21:17

reporter   ~0000570

Last edited: 23-08-03 21:19

There is a bit from my "prepare message" HTML source.

I run PHPlist on UNIX server. I use windows computer.



<p class="leaftitle">PHPlist - prepare a message for sending

<div><font style="font-size : 12px;font-family : Arial, Helvetica, sans-serif; font-weight : bold;"> good afternoon admin</font></div><div align="right">./?page=logout</div><table border=0 width="100%" height="100%"><tr><td>
<script language="Javascript" src="js/jslib.js" type="text/javascript"></script><hr>

<font color=red size=+2>Please enter a message</font>
  <form method=post >javascript:help('help/?topic=preparemessage')
<table>
<tr><td>javascript:help('help/?topic=subject') Subject:</td><td><input type=text name=subject value="test" size=40></td></tr>
<tr><td colspan=2>

</td></tr>
<tr><td>javascript:help('help/?topic=from') From line:</td><td><input type=text name=from value="me" size=40></td></tr>
<tr><td colspan=2>

</td></tr>
<tr><td colspan=2>javascript:help('help/?topic=format')Format: Auto detect <input type=radio name="htmlformatted" value="auto" >
HTML <input type=radio name="htmlformatted" value="1" >
Text <input type=radio name="htmlformatted" value="0" checked>
</td></tr>
<tr><td colspan=2>javascript:help('help/?topic=sendformat') Send as:
HTML <input type=radio name="sendformat" value="HTML" >
text <input type=radio name="sendformat" value="text" >
text and HTML <input type=radio name="sendformat" value="text and HTML" checked>
</td></tr>
<tr><td colspan=2>javascript:help('help/?topic=message') Message. </td></tr>


<tr><td colspan=2>

<IFRAME src="http://xxx.org/xxx/admin/FCKeditor/fckeditor.html?FieldName=message&Toolbar=Accessibility" width="600px" height="400px" frameborder="no" scrolling="no"></IFRAME><INPUT type="hidden" name="message" value="">
</td></tr>
<tr><td colspan=2>Message Footer.
Use [UNSUBSCRIBE] to insert the personal unsubscribe URL for each user.
Use [PREFERENCES] to insert the personal URL for a user to update their details.</td></tr>
<tr><td colspan=2><textarea name=footer cols=45 rows=5>--
[USERTRACK]

To unsubscribe from this list visit [UNSUBSCRIBE]

To update your preferences visit [PREFERENCES]


edited on: 08-23 21:19

michiel

26-08-03 10:49

manager   ~0000571

that's very odd. I cannot replicate your problem. whenever I fill out all the fields, the message is put in the queue fine. What is your PHP version?

truefresco

26-08-03 20:38

reporter   ~0000574

php 4.2.2

michiel

27-08-03 10:56

manager   ~0000575

yes, I've check it on your site and it really does not seem to work. I will investigate further.

Nikki

11-12-03 19:47

reporter   ~0000897

Last edited: 11-12-03 19:48

Hmm, I get the exact same bug, using the newest phplist available (2.6.5 and PHP 4.1.2). I will try to figure out the problem, though I doubt I can solve it.

edited on: 12-11 19:48

Nikki

12-12-03 11:02

reporter   ~0000902

Solved my problem. Turns out it must have been a ftp transfer error. When I transfered the fck library again, it all worked ok. I guess the problem I had, had nothing to do with truefresco's problem.