View Issue Details

IDProjectCategoryView StatusLast Update
0005385phpList 3 applicationCampaign Send Processpublic05-06-13 13:57
Reporterdave_graham 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.10.2 
Target VersionFixed in Version 
Summary0005385: Mailer Error: Language string failed to load: instantiate
DescriptionSet up messages to send, select list and manually process queue. PHPList attempts to process queue, states that it fails sending to 300-odd recipients, and in the event log, states the following in sequence with each user:
Mailer Error: Language string failed to load: instantiate

This happened suddenly and without any changes to phplist or the backend database.
Additional Informationrunning on virtual host
apache 1.3.34
php 4.3.10
mysql 4.0.25
TagsNo tags attached.

Relationships

duplicate of 0004756 resolveduser1308 PHPMailer doesn't properly include its language files. 

Activities

06-02-06 20:08

 

user1177

06-02-06 20:57

  ~0010326

can you check with the server admin to see if there were any global changes, patches or updates to the server since the last time phpList was working

dave_graham

06-02-06 20:59

reporter   ~0010327

yes, i can and will. thanks.

dave_graham

07-02-06 00:40

reporter   ~0010337

just got word back from my host. nothing has changed since January 1st.

dave

user1177

08-02-06 16:19

  ~0010444

possible solution: http://www.phplist.com/forums/viewtopic.php?p=14332#14332

sachas

26-05-06 15:08

reporter   ~0013995

I have experienced the same identical problem as Dave and the others. I've tried to apply the fixes mentioned here and in the duplicate one of michiel, but they haven't worked (assuming I've done things correctly). I'm new to this, and probably not as knowledgeable about this environment/language, so it could be me.

Can anyone quickly tell me whether this has been resolved, and where I will go to find the answer?

I'm not sure why everyone isn't experiencing this...my install was done automatically using Fantastico on a well-known host (BlueHost.com), and I've got to believe this is common. I haven't done anything fancy. It was working great with my test group, and then when I tried it on my list of 439, it behaved just like the others have described.

meltdown

25-07-07 17:29

reporter   ~0029780

I using phpmailer. I was getting this message:
Mailer Error: Language string failed to load: instantiate
I tried changing the path to the languages folder, but that was not the problem. It turned out the message wouldn't send because of an invalid email address.

if(!$mail->Send()){
         echo "Message could not be sent.

";
         echo "Mailer Error: " . $mail->ErrorInfo;
         exit;
      }

I added a syntax checker for email addresses and that solved the problem.

h2b2

11-08-07 16:15

manager   ~0030383

For phplist users on a Windows/IIS platform, this is a possible fix suggested by Owen: http://www.u-g-h.com/index.php/2007/04/27/phpmailer-issue-on-iis/

Ref: http://forums.phplist.com/viewtopic.php?p=31050#31050

karasu99

07-08-09 00:51

reporter   ~0050705

I've just had a similar problem with a laughably simple solution, but one that I didn't find reported here at all, so I thought I would post it for posterity.

Make sure the 'from' address is valid. Otherwise you'll get the same old "Mailer Error: Language string failed to load: instantiate" message and none of the solutions above will fix it.