View Issue Details

IDProjectCategoryView StatusLast Update
0005352phplist applicationInternationalization (l18n)public18-02-08 14:16
Reportersthibaut 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.3 
Summary0005352: accentuated characters problems in french massage queue reports
Descriptionhi
in french in the last version of web browser the accentuated characters are no more displayed using the :&acure; ... terminology it now use the ansi character directly
so i update the admin/lan/fr/processqueue.php to dislay corectly these characters
the ' character must be also replaced by ´ (0xB4) otherwise in the texts ( configuration page )it display as \'
 
i also update the admin/lan/fr/procesbounce.php to dislpay correctly the accentuated characters in the message queue windows
it seems that the accentuated chars are not display correctly when they are used in the source lines looking like :
 
<script language="Javascript" type="text/javascript">
// if (document.forms[0].name == "outputform") {
        document.outputform.output.value += "0 messages rejetés qu´il faut récupérer de la boîte aux lettres (mailbox)";
        document.outputform.output.value += "\n";
// } else
// document.writeln("0 messages rejetés qu´il faut récupérer de la boîte aux lettres (mailbox)");
    </script>

 
regards
Additional Informationattached are the two fixed files
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
has duplicate 0003302 resolveduser1177 Processing script messages don't handle HTML codes for accents properly 

Activities

03-02-06 14:09

 

fr.zip (4,100 bytes)

user1177

07-02-06 23:07

  ~0010413

thank you for the contrib.

user1177

18-02-06 18:22

  ~0010836

another solution: http://phplist.com/forums/viewtopic.php?p=14648#14648

michiel

08-08-06 22:30

manager   ~0016478

fixed it instead as indicated in http://forums.phplist.com/viewtopic.php?p=14648#14648
because that way it works for more languages than just french and it allows keeping HTML characters in the language files.