View Issue Details

IDProjectCategoryView StatusLast Update
0005332phplist applicationInterface - Backendpublic18-02-08 14:16
Reportercampbeld 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.3 
Summary0005332: Extra backslash in list name
DescriptionI save a list name with a single quote ' in the name. Then a \' appears throughout for the list name. I don't expect to see this extra backslash. I think there's a problem with quoting strings before saving to the database.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
related to 0006314 resolveduser1214 Escape character in confirmation pages 

Activities

michiel

26-04-06 18:19

manager   ~0013087


If I try this I can't reproduce it. Can you tell me where those backslashes appear? I presume it's not necessarily on the "list" page, but in other places as well?

Also, what are your settings for "magic_quotes_gpc" and "magic_quotes_runtime"?

campbeld

09-05-06 02:34

reporter   ~0013416

magic_quotes_gpc is On, magic_quotes_runtime is set to Off, this issue seems to have resolved itself. Maybe magic_quotes_qpc used to be off. I don't have control over the default PHP ini settings because PHPList is on shared hosting which doesn't allow me to override PHP settings. Some PHP scripts come with code to automatically detect magic_quotes_gpc and produce the correct results no matter whether magic_quotes_gpc is set to "On" or "Off". If I see the issue again I will submit another report with some further information to help you pinpoint the source of the problem. Is there any other information you need or functions you want me to check?

michiel

09-05-06 04:14

manager   ~0013417

that's great feedback, thanks we'll check it out and see what's wrong