View Issue Details

IDProjectCategoryView StatusLast Update
0005017phplist applicationAll Otherpublic18-02-08 14:06
Reporterbretmosley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.2 
Target Version2.10.7Fixed in Version2.10.4 
Summary0005017: Special character "o acute" is displayed as "ó" in text version of a message.
DescriptionI assume, PHPList does the following:

-> you write an HTML-message in the FCKeditor
-> FCKeditor stores this message in ASCII-style in field "message" in table "_message" in the database
-> the send process takes the content of the message field and stores it in the mail's body
-> because the send process fails to convert the HTML-ASCII back to the special chars or another plain text compatible encoding, all special chars are scrambled in plain text messages
-> HTML messages look fine, because modern E-Mail-clients are able to decode the ASCII-part of special characters in HTML-messages

Seems like this is a major bug in the program's send routine. There is a second field in the table "_message" called "textmessage" but this one's empty. Bug or feature?

What do you think?
Additional Informationsolution submitted: http://www.phplist.com/forums/viewtopic.php?p=14259

reported to work for German characters.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
has duplicate 0004460 resolveduser1177 FCKEditor can't handle accents (charset) 
has duplicate 0004676 resolveduser1177 Accentuation scrambling 
has duplicate 0003302 resolveduser1177 Processing script messages don't handle HTML codes for accents properly 
has duplicate 0006544 resolvedmichiel FCK editor causes HTML character codes to be displayed, even in text-only emails 
has duplicate 0006543 resolvedmichiel FCK editor causes HTML character codes to be displayed, even in text-only emails 

Activities

user1177

27-02-06 23:24

  ~0011049

possible solution: http://www.phplist.com/forums/viewtopic.php?p=14875#14875

papaya

03-04-06 18:41

reporter   ~0012171

The submitted solution does not seem to work with the current version (2.10.2), we still get the special chars..

michiel

08-08-06 18:45

manager   ~0016470

see also http://forums.phplist.com/viewtopic.php?p=19824

h2b2

23-10-06 18:15

manager   ~0020318

In the German forum JenGermany reports that special characters like ä, ö, ü, are displayed as ä ö ü in the text version of an HTML message (see http://forums.phplist.com/viewtopic.php?t=6884 )

The following fix apparently solved the problem:

In class.phplistmailer.php on line 61 (function add_text($text)) ,
change:
 $this->Body = $text;

to this:
 $this->Body = html_entity_decode($text ,ENT_QUOTES, 'UTF-8' );


Setup:
Phplist 2.10.3

configuration page:
Charset for HTML messages: UTF-8
Charset for Text messages: UTF-8

config.php:
define("TEXTEMAIL_ENCODING",'7bit');


I couldn't reproduce the problem on my installation, but I had USE_MANUAL_TEXT_PART enabled, which might perhaps account for that.
 

michiel

23-10-06 21:17

manager   ~0020325

yes, I can confirm that. Annoying, I thought it had been fixed, but obviously not