View Issue Details

IDProjectCategoryView StatusLast Update
0000464phplist applicationMessage Send Processpublic16-07-05 03:01
Reportermichiel 
PriorityimmediateSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.9.5 
Summary0000464: change send class to use phpmailer
Descriptionit seems phpmailer.sourceforge.net is a bit more useful for sending, and also better maintained. so it's probably a good idea to move to this class for email creation management.
TagsNo tags attached.

Relationships

related to 0002457 resolvedmichiel PHPList v2.9.5 release 

Activities

DamienMcKenna

29-03-05 06:37

manager   ~0004052

What is the status on this? What is left to be written or tested before we can replace the internal routines?

Damien

DamienMcKenna

30-03-05 06:30

manager   ~0004061

Needs bugtesting & improvements in the documentation.

DamienMcKenna

30-03-05 07:01

manager   ~0004062

If the PHPMailer is not available and you try sending a message it should give an error message, right now it seems to just stop processing.

michiel

15-04-05 15:40

manager   ~0004355

I added phpmailer to cvs and made it default switched on, but now a client reports problems with html mails being attachments inside attachments. They use a very old Outlook I think, but he preferred the old way. Now I'm puzzled what to do. It seems phpmailer created mails are better for webmail clients but fail on Outlook, aargh.

michiel

20-05-05 20:44

manager   ~0004979

I'm deleting it from 2.9.5 again, because it needs more testing before we can really use it as default.

michiel

16-07-05 03:01

manager   ~0005687

not yet set as default