View Issue Details

IDProjectCategoryView StatusLast Update
0004627phplist applicationInterface - Frontendpublic06-11-05 10:39
Reporterduncan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.8.12 
Target VersionFixed in Version2.10.1 
Summary0004627: Date display in history giving wrong date
DescriptionNot sure why but my date out of mysql in userhistory.php comes out in format YYYY-MM-DD HH:mm:ss which means the niceDate function is misinterpreting it

Have realigned for me to get it back to shape as follows
function niceDateTime($datetime) {
/* #$year = substr($datetime,0,4); DT Changed as date format is yyyy-mm-dd hh:mm:ss not yyymmddhhmmss
  #$month = substr($datetime,4,2);
  #$day = substr($datetime,6,2);
# $day = ereg_replace("^0","",$day);
  #$hr = substr($datetime,8,2);
  #$min = substr($datetime,10,2); */
  $year = substr($datetime,0,4);
  $month = substr($datetime,5,2);
  $day = substr($datetime,8,2);
  $hr = substr($datetime,11,2);
  $min = substr($datetime,14,2);

Works for me - I suspect there is a better mysql request to always get dates in a standard format. I think this may have changed when I moved to mysql 4.1.11

Cheers Duncan
TagsNo tags attached.

Activities

michiel

06-11-05 10:39

manager   ~0008438

that's resolved in 2.10.1