View Issue Details

IDProjectCategoryView StatusLast Update
0004110phplist applicationBrowser Issuespublic18-02-08 14:17
Reporterjoedan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.1 
Target Version2.10.7Fixed in Version2.10.2 
Summary0004110: bad html code leads to messy display
DescriptionIn Manage Users -> Reconcile Users -> find invalid email addresses: The browser dumps a bunch of malformed html code to the screen. See Screen capture attached. Systems details below. Reproducible in Safari 2 and FireFox.
Additional InformationYour system details are:

PHPlist version: 2.10.1
PHP version: 4.3.6
Browser: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5
Webserver: Apache/2.0.49 (Unix) DAV/2 PHP/4.3.6 mod_fastcgi/2.4.2 mod_ssl/2.0.49 OpenSSL/0.9.6i
Website: www.jsqspot.org/admin/lists/
Mysql Info: 4.0.18
PHP Modules:
xslt
xml
wddx
tokenizer
standard
sockets
session
pspell
posix
pgsql
pdf
pcre
overload
mysql
mhash
mcrypt
mbstring
ldap
imap
iconv
gd
ftp
fbsql
exif
curl
ctype
bcmath
zlib
openssl
apache2handler
Zend Optimizer
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

22-09-05 14:33

 

Picture 3.png (186,581 bytes)
Picture 3.png (186,581 bytes)

jvarrone

24-09-05 20:34

reporter   ~0007059

Open the file lists/admin/reconcileusers.php, edit line #259. The problem is a missing double-quote "

CHANGE:
        print '<input type=submit name="deletetagged" value="'.$GLOBALS['I18N']->get('Delete Tagged Users').'></form>';


TO:
        print '<input type=submit name="deletetagged" value="'.$GLOBALS['I18N']->get('Delete Tagged Users').'"></form>';

The missing quote is the 11th character from the end of the line.

michiel

28-09-05 03:08

manager   ~0007089

thanks jvarrone :-)