View Issue Details

IDProjectCategoryView StatusLast Update
0004030phplist applicationMessage Send Processpublic18-02-08 14:17
Reporterdanmills 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.10.1 
Target Version2.10.7Fixed in Version2.10.2 
Summary0004030: Sending page doesnt display the edit screen
DescriptionThe sending page is not showinbg the box of where to edit. I recently found this on a pervious release. I was told to edit the messages.php file and make sure its set to Unix LF only. This was done and nothing changed.

Now the same problem is on this release. I've worked out the file which has the problem must be either send.php or send_core.php. These files are also in unix.

Perhaps there is an isscue with the size of the page...

Can you help please.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
parent of 0004104 closed Sending page doesnt display the edit screen 
related to 0015350 resolvedmichiel "Send Message" screen is incomplete 

Activities

michiel

14-09-05 01:41

manager   ~0006785

what browser are you using? Can you disable the FCK editor (set USEFCK to 0 in the config file) and try again?

can you see it on http://www.phplist.com/lists/admin/
?

danmills

14-09-05 10:10

reporter   ~0006786

Im using IE 6.0.2900

I've swithced of the fck editor but doesnt wor. I can also see your message editor screen on http://www.phplist.com/lists/admin/

michiel

14-09-05 14:27

manager   ~0006795

so, you can see it on the demo, but not on your own installation?
what do you see? does the entire page load ok, but not display the input box for message? if that's the case it won't be the size of the page.
can you send a login for your installation, so I can have a look?
have you tried looking at it with a different browser.

danmills

15-09-05 00:21

reporter   ~0006820

michiel i e-mailed you my log in deatils for you to take a look

michiel

15-09-05 02:09

manager   ~0006822

Ok, found the reason. You're not using "require_login" and it failed because of that. I've marked it for fix in the 2.10 versions.

in send_core line 908 changed to

    if (!$from && is_object($GLOBALS["admin_auth"]) && $GLOBALS['require_login'])

maf

21-09-05 23:39

reporter   ~0006996

I am also having this issue since upgrading to 2.10.1. With IE6 (sp2), I get an empty box where the FCK editor should be showing up. I can turn off FCK in the config.php and get a plain text editor instead, but if I turn FCK back on, it's just an empty window where the editor should be. Rest of the page loads fine and it creates a draft message even though I can type in the box at all.

When I try your installation on phplist.com with IE6, it is slow to load but does load the FCK.

I have "require_login" set to 1 and it still fails.

I also changed the send_core line 908 to
    if (!$from && is_object($GLOBALS["admin_auth"]) && $GLOBALS['require_login'])
  
and this did not make a difference.

If I use FireFox it works but most of my admins do not have FireFox installed and it was working fine with IE6 in early versions of PHPlist. It just quit working with this upgrade.

michiel

22-09-05 02:06

manager   ~0006998

that sounds like a different issue and I will clone that into a new one. The original issue was caused by the admin authentication object not being loaded because require_login was off, so that it failed to load the page when trying to use that object.

mrjamin

23-09-05 22:28

reporter   ~0007055

Line 908 should be:

$adminemail = $GLOBALS["admin_auth"]->adminEmail($_SESSION["logindetails"]["id"]);

Its 907 that needs changing to what michiel suggested!

mrjamin

23-09-05 22:38

reporter   ~0007056

sorry. let me recap:

908 should be:
$adminemail = $GLOBALS["admin_auth"]->adminEmail($_SESSION["logindetails"]["id"]);

907 should be:
if (!$from && is_object($GLOBALS["admin_auth"]) && $GLOBALS['require_login']){

NOTE: michiel missed off a { from line 907

maf

23-09-05 23:53

reporter   ~0007057

The correction from mrjamin corrects the issue for me. I am now able to use FCK Editor in IE again.