View Issue Details

IDProjectCategoryView StatusLast Update
0003967phplist applicationAll Otherpublic18-02-08 14:17
ReporterAdnanKhalid 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.4 
Target Version2.10.7Fixed in Version2.10.1 
Summary0003967: Message Viewed statistics wrong for messages not being tracked
DescriptionIn the 'messages' panel under the admin account, if a message has its 'viewed' property set to 0 in the database either because no one has viewed it yet or because it is not being tracked, its viewed count and the unique views count are shown to be the same as the values for the previous message.

This bug can easily be fixed by adding the following else block in \admin\messages.php

      else
        $viewed = '';

AFTER

      if ($msg['viewed']) {
        $viewed = sprintf('<tr><td></td>
          <td align="right" colspan=2>
          '.$GLOBALS['I18N']->get("Viewed").'</td>
          <td align="center">%d</td></tr>
          <tr><td></td><td align="right" colspan=2>
          '.$GLOBALS['I18N']->get("Unique Views").'</td>
          <td align="center">%d</td></tr>
          ',$msg["viewed"],$uniqueviews[0]);
      }
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

michiel

05-09-05 14:20

manager   ~0006628

thanks for finding that!