View Issue Details

IDProjectCategoryView StatusLast Update
0003817phplist applicationInternationalization (l18n)public18-02-08 14:17
Reporteryan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.5 
Target Version2.10.7Fixed in Version2.10.1 
Summary0003817: If translation does not exist, no popup warning message appears
DescriptionThe Spanish translation is incomplete. When you're in the 'send a message' page and you don't save your changes and change tabs, a warning popup should appear. It doesn't. Pick a language where the warning message was translated, and it does appear.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 

Activities

michiel

18-08-05 23:17

manager   ~0006320

no, that's not the reason actually. I just discovered why it happens. It's when the translated string is over a few lines and the javascript fails to parse in the page (erroring on "unterminated string literal")

michiel

19-08-05 03:15

manager   ~0006322

resolved by stripping newlines from texts in translation.