View Issue Details

IDProjectCategoryView StatusLast Update
0003804phplist applicationMessage Managementpublic18-02-08 14:16
Reportergypsydogg 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.5 
Target Version2.10.7Fixed in Version2.10.1 
Summary0003804: Only have the page loads
DescriptionI had this problem with my previous version, which I'm not sure what the version was but it would only load half of the view bounces page. This time I am unable to view the messages page, which is preventing me to be able to send the message! I have seen posts in the forums but they didn't help.
TagsNo tags attached.

Relationships

related to 0003721 closed phplist 2.10.x 
has duplicate 0003901 resolvedmichiel some truncated admin pages after upgrade 
has duplicate 0003927 resolvedmichiel incomplete page creation (at installation) 

Activities

michiel

22-08-05 19:48

manager   ~0006371

i just discovered why this is, by chance

it is because the line endings in the file for some reason are Macintosh ones, and not unix. If you have commandline access to the installation on a linux machine do

dos2unix -c Mac messages.php

or alternatively load the file in an editor and save it with DOS or Unix line endings.

michiel

22-08-05 21:53

manager   ~0006373

can you confirm that this solves the problem?

thanks

skia

24-08-05 20:33

reporter   ~0006412

The messages.php, initialise.php, and members.php file in the admin folder all had Macintosh linebreaks. There may be others, but I haven't come across them yet. I converted them to Unix linebreaks using an EditPad Pro linbreak conversion feature (as I don't know if I can use commandline access), and yes, this resolved my problem. In checking some of the other files, I did notice that bounce.php is using Windows linkebreaks instead of Unix linebreaks. I understood that uploading in ascii as I did should convert all linebreaks so that they're appropriate for my hosting on Linux server. For some reason, using SmartFTP, this didn't work.

michiel

25-08-05 02:29

manager   ~0006416

It would be nice if gypsydogg can confirm this solves the problem as well, because then it's another thing to tick off and we're closer to the next release.

michiel

25-08-05 17:39

manager   ~0006446

considered resolved

gypsydogg

30-08-05 23:54

reporter   ~0006532

Sorry, I downgraded to 2.9.3 which greated a different problem. I will be upgrading back to 2.9.5 today and will report my progress. I am not familiar with what a line break is for Mac. I am a web designer/pc tech, so I'm somewhat safe, could you explain what a line break is.

gypsydogg

31-08-05 18:52

reporter   ~0006555

Anyone know what a Mac linebreak looks like?

michiel

31-08-05 18:55

manager   ~0006556

in vi/vim on my linux machine it looks like ^M

gypsydogg

31-08-05 21:28

reporter   ~0006557

OK, it's fixed. I had to copy and paste the code from my local install files on my web server. That is a weird problem. Consider this issue closed!

danmills

12-09-05 16:08

reporter   ~0006745

im still having problems with this. i've managed to change the file messages.php to Unix lines and uploaded it via ASCII but it hasnt changed anything.

Anyone know what to do?