View Issue Details

IDProjectCategoryView StatusLast Update
0003602phplist applicationSubscriber Importpublic15-07-05 02:26
Reporterjotazzu 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.4 
Target VersionFixed in Version2.9.5 
Summary0003602: If $require_login is off subscriber import with $_SESSION crashes
DescriptionI am working with a PHPlist installation with $require_login=0 and access control via HTTP authentication for the whole admin branch. This has the result, that the function session_start() is never called. But when importing emails with the topic 'import emails with different values for attributes' the $_SESSION array is used.

Due to the PHP manual, section CXI. Session Functions, a reference to a variable stored in $_SESSION like $_SESSION["import_file"] does not imply an initialisation of the $_SESSION array. session_start() has to be called explicitly before.

I don't know if this has been changed in PHP 5.x, but PHP 4.1.2 needs that call. To solve the problem a line like

session_start();

should be added at the beginning of file .../admin/commonlib/pages/importcsv.php.
TagsNo tags attached.

Relationships

related to 0002457 resolvedmichiel PHPList v2.9.5 release 

Activities

michiel

15-07-05 02:26

manager   ~0005669

Moved the session_start to a place where it is always called, even when require_login is not used.