View Issue Details

IDProjectCategoryView StatusLast Update
0003430phplist applicationSubscriber Importpublic08-07-05 14:50
Reporterstephenrs 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.8.12 
Target VersionFixed in Version2.9.5 
Summary0003430: False warnings always reported during import
DescriptionDuring a text file import with attribute vales provided for users (admin/?page=import2), if the Show Warnings checkbox is checked, warnings are always displayed, even for valid input files.

the warning comes from line 316 in importcsv.php: Warn("Record has more values than header indicated (". sizeof($values). "!=". (sizeof($_SESSION["import_attribute"]) + sizeof($_SESSION["system_attributes"]))
."), this may cause trouble: $index");

Even though the warnings are reported, the file seems to import fine.
TagsNo tags attached.

Relationships

related to 0002457 resolvedmichiel PHPList v2.9.5 release 
has duplicate 0002765 resolvedmichiel In TEST mode, import appears to fail 
has duplicate 0003603 resolvedmichiel False warnings during test import with 'import emails with different values for attributes' 
related to 0015231 resolvedmichiel False warnings during test import with 'import emails with different values for attributes' 

Activities

michiel

08-07-05 04:53

manager   ~0005565

in order to test this, can you give me an abstract (just a few lines, and if you want the emails changed) of your import file?

stephenrs

08-07-05 06:13

reporter   ~0005567

here's a clipping from a file that i recently imported, with the names all changed:

email,Agency
user1@email.net,Big greedy company
user2@email.com,Small energetic company
user3@email.com,Another Firm
user4@email.com,Last Entity

i created the "Agency" attribute before importing the list. hope this helps.

michiel

08-07-05 14:50

manager   ~0005572

i tried this list on the current CVS code and it seems to be fine, even if warnings are on