View Issue Details

IDProjectCategoryView StatusLast Update
0003428phplist applicationTemplate Managementpublic14-07-05 03:52
Reporterbbristow 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.4 
Target VersionFixed in Version2.9.5 
Summary0003428: Not Saving Images?
DescriptionAfter uploading images, it asks to save images. I upload all the images and it says "Images Stored". When I go back into the template and save it again, it asks for me to re upload all the images. It never seems to save them. What I have tried is to reinstall the database, re initialized the database. Then I installed a different copy of phplist in a different location with a new database and I am still having the same problems. What the heck is going on? I can't send any more e-mails until I resolve this as all my e-mail have embedded images.
Additional InformationYour system details are:

PHPlist version: 2.9.4
PHP version: 4.3.11
Webserver: Apache/1.3.33 (Unix) PHP/4.3.11
Website: www.housesearch.com/eflyer/lists
Mysql Info: 4.0.24-log
PHP Modules:

zip
xml
tokenizer
standard
sockets
session
posix
pcre
overload
mysql
mhash
mcrypt
mbstring
imap
gd
ftp
curl
ctype
bz2
zlib
openssl
apache
TagsNo tags attached.

Relationships

related to 0002457 resolvedmichiel PHPList v2.9.5 release 
has duplicate 0003585 resolvedmichiel More Problems with Template Images..... 

Activities

michiel

21-06-05 15:20

manager   ~0005301

how big are the images you are trying to upload? The images are stored in the database and there is likely to be a size limit to them. On the whole, you should use small images only, like a logo and possible use images pulled from a website (with the full URL) when they are larger.

bbristow

21-06-05 19:31

reporter   ~0005307

First off, thanks again for looking into this issue. It means a great deal to me that you are helping me with this. The images are around 6-10K each. I used to use this feature, and it worked great. I had my server crash and I did a fresh install of everything and I can't seem to get this feature working again. Like I said before, I even installed different copies and different versions of this software and it does not seem to matter. I don't understand what could be wrong here. The only difference is that mysql used to be 4.0.12 and now it is version 4.0.24. I can’t see why that would cause the problem though. Using this feature is the only way to go for us as we find it increases our web traffic 200% because the images are not blocked by outlook or outlook express. Here is an example of what I have been sending by e-mail:
 
http://www.housesearch.com/eflyer/html/2005-june.html


Just in case here is what phplist_templateimage looks like:

Field Type Attributes Null Default Extra
 id int(11) No auto_increment
 template int(11) Yes NULL
 mimetype varchar(100) Yes NULL
 filename varchar(100) Yes NULL
 data longblob BINARY Yes NULL
 width int(11) Yes NULL
 height int(11) Yes NULL

michiel

21-06-05 20:20

manager   ~0005310

ah, just tried on the latest CVS version, and it does look like you're right and this doesn't work. I'll assign it to the 2.9.5 tasks, so it should get into the next release

in the meantime you can probably fix it, by adding:

$id = sprintf('%d',$_REQUEST['id']);

at the top of "template.php" say just after the line:

require_once dirname(__FILE__).'/accesscheck.php';

bbristow

22-06-05 00:15

reporter   ~0005314

hmm, That did not seem to work. Any other suggestions?

michiel

14-07-05 01:35

manager   ~0005631

do you have file upload enabled ?

bbristow

14-07-05 01:38

reporter   ~0005632

If you are talking about in my php.ini, yes, file_uploads = On

michiel

14-07-05 01:43

manager   ~0005633

does file upload work in other places, like import?
I just have that feeling that it's related to files not being received. I have tried and tried, but I can't reproduce the error, so I don't know where to look

bbristow

14-07-05 01:56

reporter   ~0005635

No problem uploading in other pages. I just imported a list of 1000 e-mail addresses and it worked fine. On a side note, I also have gallery, a php image archive, with about 10,000 images that I upload through php, and that all seems to work fine.

I also looked on the forms and found a few people that are having the same problems I am having, and don't have a resolve either.

I installed phpmyadmin for this problem to look at the database:
Here is a sample of my phplist_templateimage:
   Field Type Collation Attributes Null Default Extra Action
   id int(11) No auto_increment
   template int(11) Yes NULL
   mimetype varchar(100) latin1_swedish_ci Yes NULL
   filename varchar(100) latin1_swedish_ci Yes NULL
   data longblob BINARY Yes NULL
   width int(11) Yes NULL
   height int(11) Yes NULL
 
And here are some of the rows:

  id template mimetype filename data width height
      1 1 image/png powerphplist.png [BLOB - 3.1 KB] 70 30
      2 1 image/png spacer.png [BLOB - 224 Bytes] 1 1
      3 1 image/png 01.png [BLOB - 1.3 KB] 57 29
      4 1 image/png 02.png [BLOB - 2.0 KB] 96 29
      5 1 image/png 03.png [BLOB - 2.3 KB] 135 29
      6 1 image/png 04.png [BLOB - 2.3 KB] 45 29

michiel

14-07-05 02:00

manager   ~0005636

so there are images for template 1. Does the same happen with that template?

bbristow

14-07-05 02:06

reporter   ~0005637

There were two default templates that came with phpadmin. Those two have the images that came in the database and those two seem to work. But if I try to add my own images to that template it does not work. I am frustrated with this to the point I am ready to pay you to help me fix this. Would you be willing to do that?

michiel

14-07-05 02:14

manager   ~0005638

Yes, we're kind of getting into the stage that I will need to get more deeply into your installation to figure out what's going on. I'll email you to continue.

michiel

14-07-05 03:52

manager   ~0005643

resolved in CVS and will propagate to the next release.