View Issue Details

IDProjectCategoryView StatusLast Update
0003197phplist applicationMessage Managementpublic17-09-05 12:09
ReporterLubTex 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.8.12 
Target VersionFixed in Version2.10.1 
Summary0003197: "$" misinterpreted as php variable in the text.
DescriptionIn a block of HTML text there was a price "$13.50" that came out ".50?". If I put in "\$13.50" in the text it displayed correctly. Will an addslashes take care of that or does there need to be a special str_replace that takes care of it?
TagsNo tags attached.

Activities

michiel

21-05-05 19:20

manager   ~0004995

the strange thing is that I've noticed this only occasionally and now try to reproduce it and don't manage. Can you be more specific about the content? are you putting it in with the FCKeditor, is it pulled from RSS or do you simply type it in the text box for content and send the message?

Basically what do I need to do to reproduce this problem, as I think it's still there, but I can't figure out how to make it happen.

LubTex

22-05-05 20:22

reporter   ~0004996

I was sending the message without FCKEditor using both HTML and Text sections. Here is the block of HTML that contained it.

             

<font face="Arial, Helvetica, sans-serif" size="3" color="#663300"><font color="#990000"><img src="http://www.lubbockfunclub.com/Graphics/tea%20girls%20hats.jpg" width="230" height="151" align="right">New
                Seating added for Mom & Me Tea Party this Saturday!!

                </font>
<font color="#000000" size="2">Can you believe it ...
                a tea party in a mansion for Mom and a child, plus a 5x7 keepsake
                photo ... all for $13.50 You can still make reservations until
                noon on Friday but some seatings are filling up. <a href="http://www.lubbockfunclub.com/Featured_Events.html"><font size="1">more>></font></a></font></font>

LubTex

22-05-05 20:23

reporter   ~0004997

Let me know if you want that HTML another way. Sorry.

michiel

23-05-05 01:35

manager   ~0004998

I've tried your html in the current cvs version and it seems to work ok. However, I'm keeping it open, because I have a strange suspicion there's something else the matter. Thanks for the feedback. That's really helpful.

I will update this, if I have found more information.

michiel

15-09-05 02:10

manager   ~0006829

can you upgrade to 2.10.1 and see if that solves the problem?
thanks

LubTex

17-09-05 07:14

reporter   ~0006887

I tried in 2.10.1 and it seemed to work good. Thanks