View Issue Details

IDProjectCategoryView StatusLast Update
0003143phpList 3 applicationCampaign Send Processpublic04-05-05 12:24
Reportersebwills 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.9.4 
Target VersionFixed in Version 
Summary0003143: sends out emails in quoted-printable encoding with unintended quoted-printable octet sequences
DescriptionA confirmation link that phplist sent out in an email wouldn't work in some mail readers/webbrowsers. This turned out to be because the confirmation link contained "uid=165f38d..."

This link was sent in an email with quoted-printable encoding, without any protection. In quoted printable, "=nn", where n is a digit 0-9, represents a single character.

So the email client was replacing uid=16 with uid followed by a single character. (Or even wierder stuff since the character encoded by =16 (ascii 0x16) isn't printable).

TagsNo tags attached.

Activities

michiel

04-05-05 12:24

manager   ~0004644

in the config file set email text encoding to 7bit