View Issue Details

IDProjectCategoryView StatusLast Update
0003004phpList 3 applicationCampaign Send Processpublic30-01-09 09:52
Reporteryan Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version2.8.12 
Summary0003004: problems with the 'notify' system message 'when users change their information'
Description1- a placeholder like [DOMAIN] is not replaced by the actual domain. The actual domain seems to appear in the 'configure' page when you view it, but not in the messages actually sent out by the system, where you have [DOMAIN] as is, not the actual domain.

2- the system message does not have in its source:
Content-Type: text/plain; charset="iso-8859-1"
or any other line specifying the charset. This can cause problems with certain mailers.
Messages sent out with the 'send a message' procedure do not have this problem.

3- this is more a feature request:
when you input [USERDATA], the order of the said data follows the order of the attributes as they were created in the database. This doesn't necessarily have much sense if you re-order these attributes in the registration page. For example, if you created your attributes in this order:
1.last name 2.favorite food 3.first name
and then corrected the order in the registration page so that you have 1.3.2. in that order, you will still get [USERDATA] following 1.2.3., or smith pasta john... instead of john smith pasta. !
Perhaps [USERDATA] should adopt the order of the attributes as found in the last subscribe page used by the user?
TagsNo tags attached.

Relationships

parent of 0003288 resolvedmichiel placeholders in subscription messages 
parent of 0003289 closed charset of system messages 
parent of 0003290 new order of attributes in preferences emails 
Not all the children of this issue are yet resolved or closed.

Activities

user4402

30-01-09 09:52

  ~0050311

Closing issue because it is too old. If you feel it is still relevant please add
again and give the new context. Thanks!