View Issue Details

IDProjectCategoryView StatusLast Update
0002582phpList 3 applicationSubscribe Processpublic20-05-05 20:22
Reportermp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.9.3 
Target VersionFixed in Version 
Summary0002582: Subscribe Confirmation e-mail ~ link leads to Server500 Error
DescriptionI have embedded the sign up form and confirm page into an iframe of a CMS site. Sign up page and thanks/confirm page work fine as do the links from the please confirm email, but clicking on the link in the thank you email to view / modify preferences results in a server 500 error.

Pages are not yet public at the site ~ please contact me if you would like a url to test it

Martyn
TagsNo tags attached.

Activities

DamienMcKenna

13-02-05 04:04

manager   ~0003481

Please email me a link to the test site and I will take a look at it early this coming week. dmckenna@flemployersolutions.com

Damien

mp

16-02-05 22:35

reporter   ~0003509

Damien ~ You have email, Martyn

DamienMcKenna

18-02-05 04:30

manager   ~0003563

Have registered on your site, just waiting for the confirmation email and will test it further.

Damien

DamienMcKenna

18-02-05 04:32

manager   ~0003564

Verification email arrived & worked fine, awaiting ThankYou email...

Damien

DamienMcKenna

18-02-05 04:37

manager   ~0003565

I received the emails and they all worked fine. I updated my preferences several times without any problems.

Two things I noticed:

1. The Unsubscribe page couldn't find my account. Please remove me :-)

2. I noticed that the links in the "You Made It" emails had line wraps. I suggest putting these on new lines to avoid this wrapping, this may fix it for you.

Damien

mp

20-02-05 18:45

reporter   ~0003585

Damien

Thanks for looking and for the suggestion on wrapping which I have now implented. As you expected the server 500 error has stopped and is now as follows when following the update preferences link in the confirmation email.
================================
Server error!
The server encountered an internal error and was unable to complete your request.

Error message:
malformed header from script. Bad header=404, File Not Found: index.php

If you think this is a server error, please contact the webmaster.

Error 500
www.imagewales.co.uk
Sun Feb 20 20:41:50 2005
Apache/2.0.50 (Debian GNU/Linux) mod_perl/1.99_14 Perl/v5.8.4 mod_auth_pgsql/2.0.2b1 mod_ssl/2.0.50 OpenSSL/0.9.7d

================================================

Following the unsubscribe link takes me correctly to the unsubscribe page, however following the unsubscribe process returns a user not found error and unsubscribe fails

Martyn

DamienMcKenna

24-02-05 04:25

manager   ~0003638

When I registered on your site I could get the links in the emails to work for me, not sure if anything else is going wrong there.

I did notice that the unsubscribe page was not working. Please check #2136 as this bug has been fixed for the next release.

Damien

mp

06-03-05 19:42

reporter   ~0003795

Last edited: 06-03-05 19:43

Apologies for delay in responding. The issue reported with the 404 error appears to have stopped ~ I dont know why.

I think this is a different issue to the cross reference ~ where the problem was clearly reporting that form submit submit returns to the same page saying "email required". My problem is that form submit returns the issue "user not found" which I guess is what you mean in your post 0003565 that "The Unsubscribe page couldn't find my account. Please remove me :-)"

This is an issue ~ I have had a subscriber report to me that the unsubscribe link appeared not to work.

I have subscribed myself and tried unsubscribing to hit the same error.

Any suggestions gratefully accepted

xtracked

10-03-05 17:00

reporter   ~0003849

i have experienced this same problem. I have no solutions; but, I have isolated the main point of conflict.
line 492 of "defaultconfig.inc":

    $value = eregi_replace('\[CONFIRMATIONURL\]', $url.$sep.'uid='.$uniqid.'&p=confirm', $value);

I hope I have offered a shred of assistance.
X

mp

25-03-05 20:55

reporter   ~0004044

Just wondering if anyone (else??) had any ideas on this issue. I can follow instructions to the letter but dont have the faintest clue when it comes to programming

MP

DamienMcKenna

26-03-05 04:23

manager   ~0004045

As mentioned, please upgrade to 2.9.4 and try again.

michiel

20-05-05 20:22

manager   ~0004983

issue seems to be resolved