View Issue Details

IDProjectCategoryView StatusLast Update
0002446phpList 3 applicationCampaign Send Processpublic18-02-05 17:21
Reporterbbristow 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.9.3 
Target VersionFixed in Version 
Summary0002446: Send Process Never Finishes
DescriptionI wanted to state first off that this is a wonderful product and that I am not trying to complain here, I am just trying to help you get everything working 100%. Thank you!

It appears that every time I send a Newsletter, the sending process never finishes. This is what I get in the Messages Tab:

Message info Status Action
From: E-Flyer from The Richard Bristow Group eflyer@housesearch.com
Subject: New Listing - Fair Oaks, California - 5019 Caviar Court - $1,394,500
Entered: 2005-01-10 17:10:36
Embargo: 2005-01-10 17:10:00
 inprocess

 view
48251 processed
edit
delete

When I try manually processing the messages, it just hangs on "Looking for users". I have the messages processed via this command being run by cron:

/usr/local/bin/lynx -dump 'http://www.housesearch.com/eflyer/lists/admin/?page=processqueue&login=admin&password=password'

This seems to be the only way I can get it working, but that is not the issue.

Here is what my event log looks like:
Events del page date message
3618 del processqueue 2005-01-12 10:00:00 Processing has started, 1 message(s) to process.
 
3619 del processqueue 2005-01-12 10:00:00 It is safe to click your stop button now, report w
 
3620 del processqueue 2005-01-12 10:00:00 Processing message 34
 
3621 del processqueue 2005-01-12 10:00:00 Looking for users
 
3614 del processqueue 2005-01-12 09:30:00 Processing has started, 1 message(s) to process.
 
3615 del processqueue 2005-01-12 09:30:00 It is safe to click your stop button now, report w
 
3616 del processqueue 2005-01-12 09:30:00 Processing message 34
 
3617 del processqueue 2005-01-12 09:30:00 Looking for users
 
3610 del processqueue 2005-01-12 09:00:00 Processing has started, 1 message(s) to process.
 
3611 del processqueue 2005-01-12 09:00:00 It is safe to click your stop button now, report w
 
3612 del processqueue 2005-01-12 09:00:00 Processing message 34
 
3613 del processqueue 2005-01-12 09:00:00 Looking for users
 
3606 del processqueue 2005-01-12 08:30:01 Processing has started, 1 message(s) to process.
 
3607 del processqueue 2005-01-12 08:30:01 It is safe to click your stop button now, report w
 
3608 del processqueue 2005-01-12 08:30:01 Processing message 34
 
3609 del processqueue 2005-01-12 08:30:01 Looking for users
 
3602 del processqueue 2005-01-12 08:00:00 Processing has started, 1 message(s) to process.
 
3603 del processqueue 2005-01-12 08:00:00 It is safe to click your stop button now, report w
 
3604 del processqueue 2005-01-12 08:00:00 Processing message 34
 
3605 del processqueue 2005-01-12 08:00:00 Looking for users
 
3598 del processqueue 2005-01-12 07:30:00 Processing has started, 1 message(s) to process.
 
3599 del processqueue 2005-01-12 07:30:00 It is safe to click your stop button now, report w
 
3600 del processqueue 2005-01-12 07:30:00 Processing message 34
 
3601 del processqueue 2005-01-12 07:30:00 Looking for users
 
3594 del processqueue 2005-01-12 07:00:00 Processing has started, 1 message(s) to process.
 
3595 del processqueue 2005-01-12 07:00:00 It is safe to click your stop button now, report w
 
3596 del processqueue 2005-01-12 07:00:00 Processing message 34
 
3597 del processqueue 2005-01-12 07:00:00 Looking for users
 
3590 del processqueue 2005-01-12 06:30:00 Processing has started, 1 message(s) to process.
 
3591 del processqueue 2005-01-12 06:30:00 It is safe to click your stop button now, report w
 
3592 del processqueue 2005-01-12 06:30:00 Processing message 34
 
3593 del processqueue 2005-01-12 06:30:00 Looking for users
 
3586 del processqueue 2005-01-12 06:00:01 Processing has started, 1 message(s) to process.
 
3587 del processqueue 2005-01-12 06:00:01 It is safe to click your stop button now, report w
 
3588 del processqueue 2005-01-12 06:00:01 Processing message 34
 
3589 del processqueue 2005-01-12 06:00:01 Looking for users


So for some reason it seems to be stuck. The only way I can get it unstuck is to delete the message under the message tab. I don't want to do that because it erases my records of what was sent and processed.

I also noticed that in this 2.9.3 version, I no longer receive status e-mail while the job is processing. I used to receive an e-mail about every 2000-3000 messages on the 2.8.12 version.

Am I doing something wrong here?

Your system details are:

PHPlist version: 2.9.3
PHP version: 4.3.9
Webserver: Apache/1.3.31 (Unix) PHP/4.3.9
Website: www.housesearch.com/eflyer/lists
Mysql Info: 4.1.5-gamma
PHP Modules:

zip
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mhash
mcrypt
imap
gd
ftp
curl
ctype
bz2
zlib
openssl
apache
TagsNo tags attached.

Relationships

duplicate of 0002379 resolvedmichiel Batch processing by cron job gets stuck; messages display 'inprocessing'; cannot be sent 

Activities

michiel

17-02-05 20:25

manager   ~0003552

is this still happening? Any chance to get login details (not in here, this is public, but by email) to have a look to see what's happening?

michiel

18-02-05 17:21

manager   ~0003577

probably duplicate of #2379