View Issue Details

IDProjectCategoryView StatusLast Update
0002353phplist applicationUser Managementpublic17-01-05 14:41
Reporterbbristow 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.8.11 
Target VersionFixed in Version2.9.4 
Summary0002353: Huge Bugs in User Tracking...
DescriptionI noticed a few possibly huge bugs yesterday and needed to know if there was a work around. I am running PHP List 2.8.11. I did not see a fix in the latest version, so I have not upgraded yet. I have about 51,000 users in my lists. I have sent 2 mailers to this list and that seemed to all work fine… however I started having people complain that they got the second mailer even though they unsubscribed the first time.
When I looked the user up that was complaining, I found that the user was not subscribed to any list, but still some how was getting the mailer. I checked the history and verified this. This is the first bug I noticed. It should not send mailers to people that are not subscribed to any lists. I was also told by the user that were complaining that when they used the unsubscribe link at the bottom of the e-mail, it told them that they were not subscribed to any list.
The next bug I noticed when I went to reconcile users and move everyone that was not subscribed to a list to my “Removed list”. I need to keep these users in a removed list, so that when I get my updated list once a year, I don’t re-add the people that removed themselves. Anyhow, it moved a couple hundred to the list. I tried it one more time just to make sure it got everybody and the second time it said 0 users were found. I then went back to some of the users that were complaining, and I noticed that they still did not belong to a list and were not moved to the “Removed List” like they should have been. When I am sending the mailer out, I am only selecting the list that the mailer should go to. I am NOT selecting send to all lists.
Am I overlooking something here? This is a huge issue; I can’t send any more newsletters out until this is fixed because it will send to the people who have unsubscribed. Any help would be greatly appreciated!


Here are my system details...

PHPlist version: 2.8.11
PHP version: 4.3.9
Webserver: Apache/1.3.31 (Unix) PHP/4.3.9
Website: www.housesearch.com/eflyer/lists
Mysql Info: 4.1.5-gamma
PHP Modules:

zip
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mhash
mcrypt
imap
gd
ftp
curl
ctype
bz2
zlib
openssl
apache
TagsNo tags attached.

Activities

michiel

29-12-04 14:42

manager   ~0003116

this is very hard to diagnose without sufficient access to the system. It may quite well be that all kinds of things are set up incorrectly. I haven't come across it before, which to me indicates a local problem. Not that it may be a bug, but it would be good if you could investigate the code a bit more to see what's going on. Alternatively you can also upgrade to the 2.9 versions (although they are not entirely stable yet) which has the "blacklisting" facility, which should avoid to any cost to send an email to a user, even if phplist may think that they should receive one

bbristow

29-12-04 19:27

reporter   ~0003118

Michiel,
  Thank you for the note. I have upgraded to 2.9.3 to see if this resolves my issues. It said it upgraded my DB fine, but when I do a DBcheck, I get the following error:
Database error 1146 Table 'maillist.sessiontable' doesn't exist

Any ideas?

michiel

30-12-04 10:54

manager   ~0003120

you can ignore that.

bbristow

06-01-05 01:09

reporter   ~0003147

I wanted to let you know that I upgraded and tried the "Move all users who are not on a list to a selected list" and it did not find any. However, I exported the entire list and found about 350 people that did not belong to a list. I thought this might be helpful. Thanks again!

michiel

17-01-05 14:41

manager   ~0003215

fixed by not checking that table.