View Issue Details

IDProjectCategoryView StatusLast Update
0002102phplist applicationMessage Send Processpublic03-12-04 18:47
Reporterstephenrs 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.9.4 
Summary0002102: ver 2.9.3 - Missing "Send Test Message" option
DescriptionI love the new "send message" interface, and 2.9.3 seems to have fixed some other bugs...but there is no longer a way to send a test message before queueing them to be sent to users. Pleeeeease put this feature back soon...i'm using 2.9.3 in a production environment (although i know i'm not supposed to) because i need the blacklist feature...

thanks
TagsNo tags attached.

Relationships

child of 0002456 resolvedmichiel PHPList v2.9.4 release 

Activities

stephenrs

01-11-04 22:32

reporter   ~0002462

in send_core.php i notice the following line:

#print $sendtest_content;

which comments out the "send test" button and text input box.

my questions are:

1. is this a deliberate feature change to prevent admins (or sub-admins) from skipping the message queue to send messages to users?

2. will uncommenting this line break anything?

thanks.

michiel

02-11-04 10:45

manager   ~0002466

Yes, sorry. Uncommenting that line will be fine. For some reason I forgot to do this when releasing the version.

stephenrs

02-11-04 17:53

reporter   ~0002481

actually, uncommenting the line will kind of mess up the interface a bit. the app will still work, but the "send test" input items will appear on every tab of the "send message" page. what i did was this:

 switch ($_GET["tab"]) {
    case "Attach": print $att_content; break;
    case "Criteria": print $criteria_content; break;
    case "Format": print $formatting_content;break;

#changed code below
    case "Scheduling": print $sendtest_content . $scheduling_content;
#end changed code

    case "RSS": print $rss_content;break;
    case "Lists": $show_lists = 1;break;
    case "Review": print $review_content; break;
    default:
      print $maincontent;
      break;
  }
}
#print $sendtest_content;



i also changed the appearance of $sendtest_content to fit a little better on the interface, on the scheduling page.

mgifford

02-11-04 18:46

reporter   ~0002482

I saw this as a feature and not a bug.. Having it on every page means that folks can test out different templates or change the text without jumping back..

However, there are certainly some tabs where this just doesn't make any sense.

Mike

michiel

03-12-04 18:47

manager   ~0002862

resolved in next release