View Issue Details

IDProjectCategoryView StatusLast Update
0020336phpList 3 applicationDocumentationpublic09-03-21 20:47
Reporterduncanc Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.5.5-RC1 
Target Version3.6.0 
Summary0020336: The documentation page listing plugins is not displaying any content
DescriptionThe plugin documentation page is now empty

https://resources.phplist.com/plugins/start
TagsNo tags attached.

Activities

michiel

06-03-21 13:55

administrator   ~0063821

Yes, how weird. Not sure what happened. It's a dynamic page. I'll check.

michiel

06-03-21 14:56

administrator   ~0063822

@martin has anything changed on the server recently? Like a PHP version upgrade or something?

michiel

06-03-21 15:05

administrator   ~0063823

It uses this plugin in dokuwiki: https://www.dokuwiki.org/plugin:repository

The DB is still there and has data, so that's not it.

michiel

06-03-21 15:37

administrator   ~0063824

Ah, I can see a lot of files with file dates of March 1st, so I think Martin did a system update.
I'll wait for that, before i continue. It's probably easy to fix it once we know what happened.

martin

08-03-21 15:55

administrator   ~0063826

Yes, I've updated dokuwiki

The following plugins are not present due to incompatibility:

editx
indexmenu
pluginrepo
rater

I will look into pluginrepo alternatives

martin

08-03-21 17:00

administrator   ~0063827

ok,the extrension is enabled.
but the list of plugin still doesn't work.
@michiel i don't get how this plugin works for our purpose?
The source of the page seems just missing.

martin

08-03-21 17:14

administrator   ~0063828

Last edited: 08-03-21 17:14

View 2 revisions

Actually, where should be the source of data is it different from https://www.phplist.com/knowledgebase/available-plugins/ ?
I reckon I can use data plugin instead, if pluginrepo won't work.


@mariana should it be critical, I can restore the server from backup, but i'd prefer solving this on current updated version of dokuwiki

michiel

08-03-21 20:37

administrator   ~0063829

It's not critical. I created that system about 10 years ago probably. It's a bit like translations, which haven't worked for a while either, and work again.

I will try to work it out. Yes, probably the data plugin may be a better option, but we need to check the format that all the plugin pages have been stored with.

It never really worked that well anyway. The whole tagging things worked initially, but then broke for some reason.

I'll put this on my list for the next few weeks, after I've sorted out the Docker stuff.

michiel

08-03-21 22:39

administrator   ~0063830

@martin this is dokuwiki, so no relation to our plugins https://www.phplist.com/knowledgebase/available-plugins/

This is about their plugins.

I will create a local version and figure out what's going on. We may just have to rebuild this stuff, it's quite old

mariana

09-03-21 09:39

administrator   ~0063831

I think we are overthinking this. We can simply have a static page with a list (or a table) with all the available plugins and a small description for them. It is not that we have tens of plugins coming every day, so I think it will not be hard to manage. What do you think?

martin

09-03-21 10:50

administrator   ~0063832

I'm lookinginto this, a simple bash script should do

martin

09-03-21 12:17

administrator   ~0063833

I will reorganize all data directory on the disk. It's bit of mess (originally gitbacked plugin seems to be used, there are now 2 copies of data).

martin

09-03-21 13:43

administrator   ~0063834

List of plugins has been updated

what about https://resources.phplist.com/debug_aid_plugin
should I include that too? now it's not in 'plugin' directory

I installed again gitbacked dokuwiki extension,it's good to have version control

michiel

09-03-21 20:47

administrator   ~0063837

Ok, that will do for now, but it will be good to change the way this works. I don't think this is very friendly to know.

I think a better way would be to build the list of plugins inside phpList itself, but that's another story.