View Issue Details

IDProjectCategoryView StatusLast Update
0020306phpList 3 applicationSub-adminspublic04-12-20 14:11
Reportersoftcon Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version3.5.1 
Target Version3.5.8 
Summary0020306: Default "from" email address is only correct if super admin
DescriptionI have set up the default "from" email address in the settings section (campaign settings).
When I create a new email (as super admin), this value is automatically entered in to the "from" field, as expected.

A create a second admin, NOT a super admin. I call them "editor"
I give them rights to send a message, but I untick the other 3; manage subscribers, show statics, change settings.
The "editor" logs in and creates a message, the "from" field displays their own name and email address, not the default "from" value saved in the campaign settings.
TagsNo tags attached.

Activities

softcon

04-12-20 13:45

reporter  

ss4_sending_as_editor.jpg (183,285 bytes)   
ss4_sending_as_editor.jpg (183,285 bytes)   
ss2_sending_as_superadmin.jpg (177,253 bytes)   
ss2_sending_as_superadmin.jpg (177,253 bytes)   
ss1_settings.jpg (243,093 bytes)   
ss1_settings.jpg (243,093 bytes)   
ss3_editor.jpg (167,121 bytes)   
ss3_editor.jpg (167,121 bytes)   

softcon

04-12-20 13:48

reporter   ~0063606

I had to block out some info, sorry.

I am using a custom UI, which is a copy of the "phplist-ui-bootlist" ui with some minor color/font changes. None of the functionality has been edited.

softcon

04-12-20 14:04

reporter   ~0063607

Last edited: 04-12-20 14:04

View 2 revisions

On futher inspection, this is not a bug, but is feature in admin/send_core.php line 660:

if (!isSuperUser() && USE_ADMIN_DETAILS_FOR_MESSAGES && is_object($GLOBALS['admin_auth'])) {
                $adminemail = $GLOBALS['admin_auth']->adminEmail($_SESSION['logindetails']['id']);
                if (!empty($adminemail)) {
                    $messagedata['fromfield'] = $GLOBALS['admin_auth']->adminName($_SESSION['logindetails']['id']).' '.$adminemail;
                }
 }

...can I recommend we add an additional setting that allows this default "from" message to be used if not a super-admin?

michiel

04-12-20 14:09

administrator   ~0063608

Thanks for the detailed report. But by the sounds of it, you can just switch off USE_ADMIN_DETAILS_FOR_MESSAGES

https://resources.phplist.com/system/config/use_admin_details_for_messages

put "define('USE_ADMIN_DETAILS_FOR_MESSAGES',false);" in your config file.

michiel

04-12-20 14:11

administrator   ~0063609


re-open if that didn't solve it