View Issue Details

IDProjectCategoryView StatusLast Update
0020280phpList 3 applicationSubscribe Processpublic04-11-20 16:10
ReporterArmanB Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.5.5-RC1 
Target Version3.5.7-RC1 
Summary0020280: Subscribe page doesn't accept e-mail addresses with long TLD:s
Descriptionv.3.5.7

I have an e-mail address which ends with the .cloud top level domain (TLD). Using the form on the Subscribe page, trying to subscribe results in a message saying I have to enter my e-mail address. Subscribing with an e-mail address that ends with .com works as expected. I'm assuming this is because of a check for a proper e-mail address which denies e-mail addresses with TLDs that are too long.

I haven't investigated further, but this might also affect AJAX signup or other parts where phpList might check for a valid e-mail address and denies e-mail addresses with TLDs with too many characters.
TagsNo tags attached.

Activities

michiel

30-10-20 18:26

administrator   ~0063448

Have you updated the list of TLDs? On the upgrade page, you can click the button to fetch the TLDs.

This fetches https://www.phplist.com/files/tlds-alpha-by-domain.txt which does contain CLOUD as a valid TLD.

ArmanB

30-10-20 19:00

reporter   ~0063449

Odd. I hadn't manually updated the TLDs from there. However, even after I did (from System\Upgrade phpList), the problem persists.

The same thing happens when I try to sign up to the updates newsletter (https://announce.hosted.phplist.com/lists/?p=subscribe&id=3), it says "Please Enter A Valid Email Address".

michiel

31-10-20 10:02

administrator   ~0063450

Ok. thanks. I'll try to figure out what's going on.

michiel

02-11-20 10:20

administrator   ~0063454

phpList does a check on the validity of the domain, by verifying that there is an MX record in DNS for this domain. If that doesn't exist, it considers the email address invalid as well.

Can you confirm the MX is setup and pointing to a valid SMTP server?

michiel

04-11-20 15:57

administrator   ~0063469

Ok, I found the cause. The list of TLDs is verified against an MD5 hash, and the hash was not being updated, so the refresh of TLDs failed.

If you can re-run the TLD update in phpList, it should work this time.

ArmanB

04-11-20 16:09

reporter   ~0063470

Thank you! I can confirm this now works as expected.

michiel

04-11-20 16:10

administrator   ~0063471


Great, thanks for letting us know.