View Issue Details

IDProjectCategoryView StatusLast Update
0020123phpList 3 applicationBounce Managementpublic30-11-19 20:28
ReporterMANTISFCKD 
PrioritynoneSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version3.4.8 
Target Version3.4.9Fixed in Version 
Summary0020123: Database error 1064 after processing bounces
DescriptionDatabase error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '21:31 )' at line 13

Otherwise 253 bounces were apparently processed correctly, with another 1450 waiting to be processed... ( trying again)

TagsNo tags attached.

Activities

MANTISFCKD

27-11-19 23:27

reporter   ~0062874

tried again... got further this time!!

Processed messages will be deleted from mailbox
Database error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '21:26 )' at line 13

1025 done
Closing mailbox, and purging messages
Processing bounces based on active bounce rules
85 bounces processed by advanced processing
1216 bounces were not matched by advanced processing rules
Identifying consecutive bounces
total of 1169 subscribers processed

---

if I could figure out which order these get grabbed from the mailbox in, then I could attach the troublemaking email.. but for now I just have to keep at it until there's only one left?

MANTISFCKD

27-11-19 23:32

reporter   ~0062875

still at it... only 120 left!

100 done
Closing mailbox, and purging messages
Processing bounces based on active bounce rules
13 bounces processed by advanced processing
1363 bounces were not matched by advanced processing rules
Identifying consecutive bounces
total of 1249 subscribers processed

Processed messages will be deleted from mailbox
Database error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '21:41 )' at line 13

MANTISFCKD

27-11-19 23:36

reporter   ~0062876

well that is interesting - it just silently errors now... there are still 120 items in the box

0 bounces to fetch from the mailbox
Processing bounces based on active bounce rules
0 bounces processed by advanced processing
1368 bounces were not matched by advanced processing rules
Identifying consecutive bounces
total of 1249 subscribers processed

I'll guess I'll just start moving random ones to a temporary folder until I get this narrowed down...

MANTISFCKD

28-11-19 00:01

reporter   ~0062877

Last edited: 28-11-19 00:11

View 2 revisions

hmmm.. after much trial and error I got it down to the very last 'killer message"but in fact, that one went through fine as WELL.
So the bad one got DELETED somehow? I guess I'll never know...

MANTISFCKD

28-11-19 19:17

reporter   ~0062878

Whoops - looks like this is an ogoing thing - more bounce processing today:

Database error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '14:41 )' at line 13
Database error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '18:33 )' at line 13

Incidentally, running PHP Version 7.3.12, and mysqlnd 5.0.12-dev , on MySQL
Server type: MySQL
Server version: 5.7.28 - MySQL Community Server (GPL)

-----

17 bounces to fetch from the mailbox
Please do not interrupt this process
Closing mailbox, and purging messages
Processing bounces based on active bounce rules
0 bounces processed by advanced processing
1573 bounces were not matched by advanced processing rules
Identifying consecutive bounces
total of 1352 subscribers processed

MANTISFCKD

28-11-19 23:02

reporter   ~0062880

Here is something a little different... there were actually 31 messages in the bounce box, and after bounce processing:

4 bounces to fetch from the mailbox
Please do not interrupt this process
Closing mailbox, and purging messages
Processing bounces based on active bounce rules
0 bounces processed by advanced processing
1634 bounces were not matched by advanced processing rules
Identifying consecutive bounces
total of 1364 subscribers processed

Processed messages will be deleted from mailbox
Database error 1366 while doing query Incorrect string value: '\xFE\xFE\xEC\xE0 \xF0...' for column 'header' at row 1

MANTISFCKD

28-11-19 23:12

reporter   ~0062881

Keeping at it ( have 1500 bounces to deal with today) ...

Processed messages will be deleted from mailbox
Database error 1064 while doing query You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '22:35 )' at line 13

This from a run of only 17 bounce mails ( all which were successfully deleted after processing...)

michiel

30-11-19 20:27

manager   ~0062882

Database error 1064 is a missing column or table.

Can you go to System -> Database check and see if it passes. If not, you need to create the missing columns.

michiel

30-11-19 20:28

manager   ~0062883


Closing as "unable to reproduce"

The forums are a better place to request help.