View Issue Details

IDProjectCategoryView StatusLast Update
0002010phpList 3 applicationBatch Processingpublic06-02-09 23:09
Reportermartymoloney 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0002010: PHPMailer modification to get around SMTP Mailer Error
DescriptionI was getting error messages with the SMTP class in PHPList like:

Mailer Error: Language string failed to load: recipients_failed

 
Additional InformationIt turned out that I had to add authentication into class.phplistmailer.php starting at line 30...

$this->port = 25;
$this->helo = '';
$this->auth = TRUE;
$this->user = 'your_email_address';
$this->pass = 'your_password';

Note that I overwrote the existing "helo" with the above.
TagsNo tags attached.

Relationships

duplicate of 0004756 resolveduser1308 PHPMailer doesn't properly include its language files. 

Activities

afx114

17-11-05 09:41

reporter   ~0008687

This is actually a symptom of another bug. Please see http://mantis.tincan.co.uk/view.php?id=4756

duncan

21-11-05 06:13

reporter   ~0008769

You need to be careful modifying the HELO as some mail systems expect a valid HELO and will treat you as SPAM if it doesn't look right. Usually though the HELO should come from the server and be independent of our systems

user4402

06-02-09 23:09

  ~0050383

Closing issue because it is too old. If you feel it is still relevant please add again and give the new context. Thanks!