View Issue Details

IDProjectCategoryView StatusLast Update
0020005phpList 3 applicationGeneralpublic21-12-20 09:44
Reporterduncanc Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.4.3 
Summary0020005: php warning issued on each page load
DescriptionWith error reporting enabled this warning is issued on every page

[01-Jul-2019 06:45:13 UTC] PHP Warning: file_get_contents(): Filename cannot be empty in /home/dcameron/public_html/lists/admin/updateLib.php on line 10

the line identified is in function getCurrentphpListVersion()

    $version = file_get_contents($path);

that is called from index.php line 532

        if (showUpdateNotification() && (getCurrentphpListVersion() !== false) && extension_loaded('curl')) {

This function doesn't make much sense, because the phplist version is available as the constant VERSION, but even calling it is unnecessary. It is not clear exactly what condition it is trying to handle.
TagsNo tags attached.

Activities

duncanc

20-12-20 06:57

updater   ~0063665

@mariana This problem has been fixed by https://github.com/phpList/phplist3/pull/715

mariana

21-12-20 09:44

administrator   ~0063667

Great then. Closing this issue.