View Issue Details

IDProjectCategoryView StatusLast Update
0019974phpList 3 applicationGeneralpublic11-06-19 14:04
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.4.2 
Target Version3.4.3Fixed in Version 
Summary0019974: Linking from Manage Plugins page to Settings page sometimes does not work
DescriptionOn the Manage Plugins page each plugin can have a link to its group of settings on the Settings page. The plugin's category, such as ckeditor, is used for the target id attribute and for the # fragment on the linking URL, e.g.

https://mysite.com/lists/admin/?page=configure&tk=e1b7d695f7f1c8298576529f07e9ae81#ckeditor

When the category contains spaces, such as 'Campaign statistics', then an invalid id is generated - spaces are not allowed. This seems to work with the Dressprow theme, probably because it is handled by the browser, but with Trevellin there is a javascript error and the linking does not work, see the attached screenshot.
TagsNo tags attached.

Activities

duncanc

09-06-19 11:11

updater  

javascript error.png (27,334 bytes)
javascript error.png (27,334 bytes)