View Issue Details

IDProjectCategoryView StatusLast Update
0019877phpList 3 applicationGeneralpublic19-04-19 14:43
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformLinuxOSFedoraOS Version26
Product Version3.4.0 
Target Version3.4.2Fixed in Version 
Summary0019877: Re-add JS script type attribute to updated references to jQuery scripts
DescriptionThe type="text/javascript" attributes were recently removed from references to jQuery scripts. This causes browser warnings. Re-add these type attributes.

Eg:
https://github.com/phpList/phplist-ui-bootlist/blob/master/footer_minified.inc#L27
https://github.com/phpList/phplist-ui-bootlist/blob/master/frontendfooter.php#L15

The same goes for the bootlist theme.
Additional InformationThe new jQuery version files path: admin\ui\phplist-ui-bootlist\js directory.
Edited files: frontendfooter.php and footer_minified.inc
TagsNo tags attached.

Activities

kgarland

15-04-19 17:58

reporter   ~0062089

I noticed that for version 3.4.1, that Jquery1.5.2 is in \phplist-3.4.1\public_html\lists\js . Is there a plan to update this for 3.4.2?

Brunhilda mentioned in https://mantis.phplist.org/view.php?id=19755 , that the fix was available in https://github.com/phpList/phplist3/pull/499