View Issue Details

IDProjectCategoryView StatusLast Update
0019838phpList 3 applicationAutomatic updaterpublic08-04-19 10:34
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.4.0 
Target VersionFixed in Version 
Summary0019838: phplist fails when php does not include curl
DescriptionThe functionality to check for a new release assumes that php includes the curl extension.
Now, 3 days after upgrading to 3.4.0, an installation is failing on every page because of the check for a new release.

Elsewhere in phplist there are tests for curl being available then, if it is not available, then the functionality is suppressed in some way

e.g. when checking for new translations

I made a similar comment that curl is not mandatory when the updater was first released
 https://discuss.phplist.org/t/phplist-3-3-7-release-candidate-ready-for-testing/4738/6
so this should already be known.
TagsNo tags attached.

Activities

duncanc

22-03-19 08:49

updater  

michiel

24-03-19 17:57

manager   ~0062028



@xheni @samtuke any location fetching data from a remote server should use the "fetchUrl" function:

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/lib.php#L1163

This (a) caches things, and (b) determines if curl is available and use other options when not.

Actually, fetchUrl can do with a review, and possibly the addition of simply fetching with "file_get_contents" which now happily fetches URLs as well.

xheni

25-03-19 10:19

administrator   ~0062031

When I updated PHP to PHP 7.3, I got a blank page because the SimpleXML module was missing, therefore I created this issue: https://mantis.phplist.org/view.php?id=19837
curl is in system requirements of phpList: https://resources.phplist.com/system/start
The check for required PHP modules in updater is already done and I can do so for phpList3 as well, for every required PHP module.