View Issue Details

IDProjectCategoryView StatusLast Update
0019815phpList 3 applicationphpListpublic12-03-19 13:20
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionopen 
Product Version3.4.0-RC1 
Target VersionFixed in Version 
Summary0019815: Dressprow theme is affected by jquery upgrade
DescriptionThe change to upgrade jquery does not appear to have considered the Dressprow theme. The file admin/ui/dressprow/pagetop.php still refers to 1.7.1 and jqueryui 1.8.1

<!-- initial styles and JS from basic application -->
<script type="text/javascript" src="js/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="js/jquery-ui-1.8.1.all.min.js"></script>
<script type="text/javascript" src="js/jquery.tools.scrollable.js"></script>
<script type="text/javascript" src="js/phplistapp.js"></script>

TagsNo tags attached.

Activities

duncanc

11-03-19 11:16

updater  

duncanc

11-03-19 11:23

updater   ~0062001

To clarify, this problem happens with
define('USE_MINIFIED_ASSETS', false);

which causes the individual js files in the admin/js directory to be requested. When that define is set to true then a minified file from the theme's own directory is used. That does exist but I can't tell which version of jquery is included.

brunilda

12-03-19 13:20

manager   ~0062006

Thanks @duncan for reporting this.

I have changed pagetop.php file to call the new jQuery version.

The PR link:
https://github.com/phpList/phplist-ui-dressprow/pull/38