View Issue Details

IDProjectCategoryView StatusLast Update
0019778phpList 3 applicationAutomatic updaterpublic19-02-19 14:48
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.9 
Target VersionFixed in Version 
Summary0019778: phplist zip file contains __MACOSX directory
DescriptionThe zip file that is downloaded by the automatic updater includes a __MACOSX directory.
See https://superuser.com/questions/104500/what-is-macosx-folder for an explanation of what the directory is and why it is not needed.

That directory contains more files than the actual distribution and has the effect of lengthening the time taken to unzip the file, possibly causing a timeout. I have noticed the unzipping taking as long as one minute.

Can the zip file be created without the __MACOSX directory?
TagsNo tags attached.

Activities

duncanc

18-02-19 22:20

updater  

xheni

19-02-19 09:30

administrator   ~0061912

@duncan well spotted. That seems to be a folder generated by my macOS, I will update the zip file in the server. Sorry for the inconvenience.

samtuke

19-02-19 11:11

administrator   ~0061913

Can we add a .gitignore file to prevent this?

suela

19-02-19 14:48

administrator   ~0061914

the download server has now been updated so this should now be resolved.