View Issue Details

IDProjectCategoryView StatusLast Update
0019755phpList 3 applicationGeneralpublic18-02-19 10:58
Reportersamtuke 
PriorityhighSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformLinuxOSFedoraOS Version26
Product Version3.3.9 
Target Version3.4.0Fixed in Version 
Summary0019755: jQuery in phpList 3 core outdated
DescriptionScript: phplist-3.3.8\public_html\lists\admin\js

It looks like it is using the JQuery verison 1.7.1. It looks like there are security vulnerabilities for any version of Jquery before 1.9.0.

https://www.cvedetails.com/vulnerability-list/vendor_id-6538/product_id-11031/version_id-235564/Jquery-Jquery-1.7.1.html 2

Update jQuery to the latest.

Originally reported by kgarland here: https://discuss.phplist.org/t/jquery-version-1-5-2/4957
TagsNo tags attached.

Activities

duncanc

11-02-19 22:31

developer   ~0061875

The bootstrap theme also has jquery, in this case jquery-1.12.1.min.js

Maybe there is a way to rationalise these?