View Issue Details

IDProjectCategoryView StatusLast Update
0019623phpList 3 applicationAutomatic updaterpublic09-08-19 12:50
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Product Version 
Target VersionFixed in Version3.4.0 
Summary0019623: Label the following message as an error: 'No write permission for the following files:'
DescriptionThe following message represents an error: 'No write permission for the following files:'

Make this fact clear by adding 'Error: ' before it.
TagsNo tags attached.

Activities

grindlay

09-01-19 17:54

reporter   ~0061681

Have this error on Win10 3.3.7-RC1. The file list is blank. Is this expected ?

phplist.png (21,328 bytes)
phplist.png (21,328 bytes)

xheni

10-01-19 23:45

administrator   ~0061687

@grindlay Thanks for testing. What windows filesystem are you using? Can you please check apache error.log, browser network response and console?
For the automatic update to continue, the whole phpList directory and the files within it must be writable by the HTTP user under which your Apache web server is running.

grindlay

17-01-19 19:39

reporter   ~0061743

Sorry I should have been more specific, windows browser client but PHPList is running on CentOS 6.10/PHP7.2.
All my files have 0644 permission and directories have 0755.
Nothing in /var/log/apache2/error_log and nothing in the local PHP error_log either.
HTTP user is the account owner user:user.
Apache uses PHP-FPM.

xheni

15-02-19 19:19

administrator   ~0061907

@samtuke I think you had the same issue once. Did you manage to fix it? It could be related to SELinux.

samtuke

16-02-19 08:13

administrator   ~0061908

@xheni I didn't resolve it, but I don't think it was caused by SELinux (as disabling it made no difference).

grindlay

16-02-19 13:25

reporter   ~0061909

SELinux is disabled on my system
root@ds [~]# sestatus
SELinux status: disabled
I still have the issue on 3.3.9RC3

Fremois

31-07-19 11:48

reporter   ~0062593

I have the same issue : No error in Apache log file.
User and group of phpList folder is the Apache's owner/group (www-data)

Version : PHPList 3.4.0 with PHP 7.0.33
OS : 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux with SE Linux disables